请选择 进入手机版 | 继续访问电脑版

HPsocket

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 76|回复: 3

[易语言] hpsocket端口转发

[复制链接]

154

主题

189

帖子

7400

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
7400

推广达人

QQ
发表于 2022-7-6 09:58:53 | 显示全部楼层 |阅读模式
易语言hpsocket端口转发,此源码是转载别人的收集整理一下一起玩玩吧,以后会收集一些网络上相关HP 的代码贴在本网,缺少模块的话可以在本论坛下载相关的模块即可 DLL可以用中文模块的命令输出一定要跟模块版本匹配才可以
$ ~1 o. ~: W5 z" ]: @7 L. u6 I1 V5 w1 m! ?. h5 v  |
[AppleScript] 纯文本查看 复制代码
.版本 2
.支持库 iext

.子程序 _启动转发_被选择
.局部变量 本地端口, 整数型
.局部变量 目标ip, 文本型
.局部变量 目标端口, 整数型
.局部变量 l_Ret, 整数型
.局部变量 名字, 文本型

.如果真 (n_ForwardList.现行选中项 ≠ -1)
    .如果真 (n_ForwardList.取表项数值 (n_ForwardList.现行选中项) ≠ 0)
        返回 ()
    .如果真结束
    本地端口 = 到整数 (n_ForwardList.取标题 (n_ForwardList.现行选中项, 3))
    目标ip = n_ForwardList.取标题 (n_ForwardList.现行选中项, 1)
    名字 = n_ForwardList.取标题 (n_ForwardList.现行选中项, 0)
    目标端口 = 到整数 (n_ForwardList.取标题 (n_ForwardList.现行选中项, 2))
    创建服务 (名字, 到整数 (本地端口), 到整数 (目标端口), 目标ip)
    .如果真 (l_Ret = 0)
        ' 信息框 (“转发启动失败”, #警告图标, , )
        ' 返回 ()
    .如果真结束
    n_ForwardList.置图片 (n_ForwardList.现行选中项, 0, 1)
    n_ForwardList.置表项数值 (n_ForwardList.现行选中项, l_Ret)
$ c% _6 \4 Z- L/ [; |$ l1 M
: O- w( D  Q. f. n0 U
游客,如果您要查看本帖隐藏内容请回复
4 u; d- |! l$ F8 q% A8 Q1 Z6 R

0

主题

2

帖子

20

积分

新手上路

Rank: 1

积分
20
发表于 2022-7-9 10:37:36 | 显示全部楼层
非常感谢楼主分享
回复

使用道具 举报

1

主题

6

帖子

24

积分

新手上路

Rank: 1

积分
24
发表于 2022-8-25 21:38:10 | 显示全部楼层
学习学习。。
回复

使用道具 举报

1

主题

5

帖子

22

积分

新手上路

Rank: 1

积分
22
发表于 6 天前 | 显示全部楼层
xuex学习一下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|HPsocket-国产高性能通讯框架 ( 豫ICP备19038015号-1 )|网站地图 *// Яндекс.Метрика *// free website promotion

GMT+8, 2022-9-25 17:01 , Processed in 0.112669 second(s), 36 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表